Keyboard Not Working in Xorg After Booting Ubuntu

I’ve had a weird issue a couple of times on my work computer, where the keyboard and the mouse does not respond in Xorg after rebooting. As I only reboot my work computer every 80 days or so, I tend to forget the reason why it happens between each boot sequence.

The reason why the mouse and keyboard does not work after rebooting at my computer is that HAL or DBUS failed to start. I’ve not dug further into this issue, as it doesn’t happen very often. The solution:

(you can switch to a text console by pressing ctrl+alt+f1, your keyboard will work there)

/etc/init.d/dbus start
/etc/init.d/hal start

Restart X / GDM:

/etc/init.d/gdm restart

Switch back to the Xorg terminal (alt+f7) and hopefully your keyboard and mouse will yet again work!

9 thoughts on “Keyboard Not Working in Xorg After Booting Ubuntu”

  1. How are you supposed to press ctrl+alt+f1 when the keyboard is not working???

  2. The keyboard itself works, but X is not receiving any input from it. ctrl+alt+f1 is trapped earlier in the API, switching from the X server to the regular text console, even though GDM doesn’t see any input.

  3. Thanks, this helped me.

    I also got the keyboard and mouse to work with the old xorg.conf – but then it wasn’t using HAL i guess, so nicer get things working as it should.

  4. hi, i am having this same problem but pressing ctrl alt f1 does nothing, my mouse and keyboard were working fine but then i rebooted and now they dont work, i am very new to ubuntu and would appreciate any detailed step by step help in fixing this problem, thank you.

  5. Ok the ctrl+alt+f1 did nothing for me either, but what I did was when the system first booted into grub I booted the Ubuntu generic kernel in the (recovery mode)
    logged in as super user and then I went into /etc/init.d/
    loaded gdm flat file with view (vi editor) and added the two processes at the top of the flat file before gdm booted as shown below:
    /etc/init.d/dbus start
    /etc/init.d/hal start

    wrote the flat file and rebooted…. these two processes started before gdm therefore everything worked. I believe my gdm quit working when I turned on the cups printer process… I can’t remember what all I did because I was jacking around with all the process trying to figure out which ones I really did not need. Note to self dbus is needed….
    quit jacking around with the system until you have backed up all your design work.

  6. Apologizes for any bad English. Also because I am a newbie, too.

    I finished to fix an ubuntu 10.04 where the ps2 keyboard and usb mouse hangs at login screen (but both work in livecd).

    ctrl+alt+f1 did not work. Actually the gdm edit stuff caused a continuous loop, reloading dbus and using more memory, up it hangs, because my problem was not with dbus…

    So I turned on the machine with keyboard and mouse disconnected (may need to edit bios to allow to start without keyboard), and after the X login screen was up I connected keyboard and mouse and it works for that session.

    In a terminal, sudo apt-get upgrade show me that previous upgrade was interrupted by the pc user (newbier than I)… so I started to upgrade again…

    sudo apt-get clean
    sudo apt-get update
    sudo dpkg –configure -a (apt-get told me to do this)
    sudo apt-get upgrade
    sudo apt-get update
    sudo reboot (to restart the machine)

  7. These instructions worked great! Upgraded to 11.10, keboard lights would come on after post, then as soon as Linux started to boot, keyboard lights would go out and I would get no keyboard or mouse activity. Followed instructions above, fixed issue – THANKS!!

Leave a Reply

Your email address will not be published. Required fields are marked *